Fujitsu U810 - Ubuntu upgarde to 10.04, Lucid Lynx

update 2010.09.02: I recently installed the kernel 2.6.36, and then,

- suspend/resume works as expected

- external monitor works great !!

- mouse pointer is ok

- boot is as long as expected

=> so, now I can recommend to upgrade to lucid, as long as you install this kernel release.

To install this kernel in ubuntu, read this post.

This last week-end I took fresh air and made the brave decision to upgrade my U810 to the latest ubuntu, lucid lynx, 10.04, released two weeks ago.

Long story short: don't do it yet.


- suspend / resume was working flawless in 9.04, and fast; with 10.04, something strange is happening, many times on opening the screen does not resume, and even resuming sliding the power button the machine resumes but external usb devices and monitor don't work, and I have to go through a several Ctr+Alt+F1 - Ctrl+Alt+F7 sequences to have usb devices working back

- external display behaves strange: I wrote 'nomodeset' option in the kernel load commenad line at grub, to have the external monitor working. But :

Working with the monitor tool in System -> Preferences is like a nightmare, sometimes it works, other doesn't, so I have to keep trying selecting the external monitor, then it gives some error, then I select it again, then it works , ....

Many times, when the screen-saver launches, the external monitor gets disabled (some other it doesn't), and I have to go to the Monitor tool nightmare

- the mouse pointer is broken; botom 30% is the usual arrow-bottom, but the 70% rest is the text-entry cursor; even it seems a small annoyance, its a big usability issue; many times I end up pressing options I didn't want to !

- booting seems to me much longer than with previous version ....

In ubuntu 9.04 everything was working very fine, very fast, not even a slight issue; with this version, the problems are too serious to recommend and upgrade, so just wait.

I'll be updating my system as new updates are available, and I'll post back when the issues described are solved.

BTW: the touchscreen driver compiled and works as usual !